Ignorer la navigation

Imbrication de trois fonctions SI

Une nouvelle règle de gestion est imposée : les étudiants n'ayant pas obtenu au moins 8/20 ne sont pas admis au rattrapage, ils sont donc ajournés.

L'énoncé littéral devient donc :

SI Note est plus grand ou égal à 10 ALORS

SI Sexe est égal à "M" ALORS afficher "Certifié" SINON afficher "Certifiée"

SINON

SI Note est plus grand que 8 ALORS afficher "Rattrapage" SINON "Ajournement"

La formulation "Ajournement" est pratique, elle ne nécessite pas de féminisation.

Activité

Créez une nouvelle colonne Résultat ter

Modifiez la formule en conséquence, attention au nombres de parenthèses.

Aide  ; structure de l’imbrication

=SI(C5>=10;SI(B5="M" ;"Certifié" ;"Certifiée" );SI( ; ; ))

La solution

=SI(C5>=10;SI(B5="M" ;"Certifié" ;"Certifiée" );SI(C5>=8;"Rattrapage";"Ajournement"))

Activité

Pour les braves uniquement !

Modifiez votre formule afin de suivre cette nouvelle règle de gestion qui n'utilise pas le terme "Ajournement" mais "Ajourné(e)" :

L'énoncé littéral

SI Note est plus grand ou égal à 10 ALORS

SI Sexe est égal à "M" ALORS afficher "Certifié" SINON afficher "Certifiée"

SINON

SI Note est plus grand que 8 ALORS afficher "Rattrapage" SINON

SI Sexe est égal à "M" ALORS "Ajourné" SINON "Ajournée"

Solution

=SI(C5>=10;SI(B5="M";"Certifié";"Certifiée");SI(C5>=8;"Rattrapage";SI(B5="M";"Ajourné";"Ajournée")))