Ignorer la navigation

La fonction SI

La fonction SI

Dans certaines situations, on peut avoir besoin de faire varier le résultat d'une formule selon certaines conditions. Au lieu d'écrire plusieurs versions de la formule, on peut tenir compte de la condition à l'intérieur de la formule grâce à la fonction SI. 

Dans la colonne D de la feuille ouverte, on veut afficher "Majeur" ou "Mineur" selon l'âge inscrit dans la colonne C.

Pour cela, on utilise la fonction SI qui admet 3 arguments séparés par des points-virgules.

=SI (condition ; valeur si vrai ; valeur si faux)

Première argument : la condition. Elle consiste à réaliser une comparaison ou un test sur le contenu d'une autre cellule. On utilise les opérateurs de comparaison : 

=  est égal à
<>  est différent de
<  est plus petit que
<=  est plus petit ou égal à
>  est plus grand que
=>  est plus grand ou égal à

Le second argument est la valeur affichée ou calculée si le résultat de la condition est vraie.

Le troisième argument est la valeur affichée ou calculée si le résultat de la condition est faux.

Les deux derniers arguments sont optionnels, ils peuvent être : 

  • une constante au format texte entre guillemets ex : "Majeur"
  • une constante au format numérique ex : 20%
  • une formule quelconque avec des fonctions ex : SOMME(A10:B30) 

Dans le cas présenté, on peut écrire la condition littéralement :

Si : condition

Alors : argument Vrai

Sinon : argument Faux

Si C3 est plus grand que 18 alors afficher Majeur sinon afficher Mineur

Pour calculer le seuil de majorité, on utilisera les données de la colonne C présentées sous forme d'années mais exprimées en nombre de jours depuis la date de naissance.

Une année compte en moyenne 365,24 jours à multiplier par 18 (afin de tenir compte des années bissextiles), le seuil de majorité est donc fixé à 6574 jours.

SI est une fonction un peu complexe à écrire, c'est pourquoi il est conseillé d'utiliser l'assistant fonction qui propose une aide à la rédaction :

La formule qui été inscrite en D3 est :

Activité

La formule inscrite précédemment ne donne pas satisfaction, en effet, elle considère qu'une personne est majeure le lendemain de son anniversaire.

Modifiez et appliquez la formule correcte en D3:D8, utilisez l'assistant fonction.

Solution

La formule à inscrire est :

=SI(C3>=6574;"Majeur";"Mineur")