Ignorer la navigation

SI, fonctions et formules

On souhaite désormais savoir dans combien de temps les mineurs seront majeurs.

Expression littérale de la formule :

SI l'individu est mineur ALORS calculer la différence entre sa majorité et son âge

Activité

Quelle formule inscrite en E3 permet-elle d'afficher ce résultat ?

Solution

La formule à inscrire est :

=SI(C3<6574;6574-C3)

Il y a deux problèmes dans ce résultat :

  • L'absence du dernier argument dans la fonction SI provoque l'affichage FAUX.
  • Le format d'affichage date ne convient pas.

Résolution : 

Modification de la formule, on indique à Calc de ne rien afficher si la condition est fausse. Pour cela, on ajoute l'argument SINON avec une chaîne vide :

=SI(C3<6574;6574-C3;"")

Ensuite, on modifie le format d'affichage, sélectionnez E3:E8 et appliquez le format nombre :

Enfin appliquez une bordure, vous obtenez :