Ignorer la navigation

Solution 1 - concaténation de SI

La solution la plus simple consiste à mettre en œuvre la concaténation de cellules, en effet, la féminisation du résultat peut se réaliser en ajoutant en e.

Notre formule contiendra donc deux fonctions SI reliées par l'opérateur &.

Activité

En D2, inscrivez la formule permettant d'afficher "Certifié" ou "Ajourné" puis dupliquez cette formule aux cellules suivantes de la colonne.

Solution

=SI(C2>=12;"Certifié";"Ajourné")

Il faut maintenant prendre en compte le sexe, ajoutez l'opérateur de concaténation suivi d'une nouvelle fonction SI permettant d'afficher le e du féminin.

Aide  ; compléter avec cette structure

 & SI(; ; )

Solution

La formule complète :

=SI(C2>=12;"Certifié";"Ajourné") & SI(B2="F";"e";"")

La seule difficulté de cette formule réside dans la structure de la fonction SI, du nombre de parenthèses (autant en ouverture qu'en fermeture) et de la distinction entre les cellules de texte et les cellules numériques.