Ignorer la navigation

Solution 2 - imbrication de SI

Si on estime qu'un étudiant n'ayant pas obtenu la moyenne est inscrit en rattrapage,  la solution énoncée ne fonctionne pas, la formule retournerait Rattrapagee aux étudiantes.

Il faut donc imbriquer les fonctions SI de manière à réaliser des choix à l'intérieur de la fonction.

Énoncée littéralement, notre formule pourrait être :

SI Note est plus grand ou égal à 10 ALORS

SI Sexe est égal à "F" ALORS afficher "Certifiée" SINON afficher "Certifié"

SINON afficher "Rattrapage"

ou encore

SI Note est plus grand ou égal à 10 ALORS

SI Sexe est égal à "M" ALORS afficher "Certifié" SINON afficher "Certifiée"

SINON afficher "Rattrapage"

On constate simplement que l'argument VRAI du premier SI est occupé par une autre fonction SI permettant de déterminer la chaîne de caractères à afficher selon le sexe du candidat. Une nouvelle fois, la difficulté réside dans l'écriture de la fonction SI et bien respecter le nombre de parenthèses ; les guillemets et le nombre de points-virgules.

Activité

Modifiez votre tableau en ajoutant une colonne :

Dans la cellule E2, saisissez la formule permettant de satisfaire la nouvelle contrainte.

Pour vous aider, consultez les aides progressives. Jouez le jeu et essayez de trouver la solution par vous-même :

Aide 1 ; structure de la formule

=SI( ;SI( ; ; ); )

 Aide 2 ; toujours pas d'idée ?

=SI(C2>=10;SI( ; ; );"Rattrapage")

Aide 3 ; vraiment ?

=SI(C2>=10;SI(B2="F" ; ; );"Rattrapage")

Solution

=SI(C2>=10;SI(B2="F" ;"Certifiée" ;"Certifié" );"Rattrapage")



Avez-vous bien compris ?

Modifiez la formule en inversant le test du second SI ("M" par "F" ou inversement).